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The MyCheck Book 3 desktop application is designed to help you record Credits and 
Debits for you and/or your clients.  
Create and use virtual ‘Checkbooks’ to record this Credit/Debit data - specify exactly 
when transactions occurred, whether it was a Salary or a Check who the payee was 
etc.  
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In this pane you will find an alphabetical list of Checkbooks to the left of which there 
are 3 buttons for deleting, editing and viewing each Checkbook respectively. 
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· To create a new Checkbook, choose ‘New Checkbook’ from the ‘Edit’ menu.  
· This will open the ‘Add Checkbook’ box.  
· Enter the new Checkbook’s name in the text field as well its ‘Starting 

Balance’ & the ‘Starting Check Number’1 and then click OK. 
· The new Checkbook will be added to the list in the ‘My Checkbooks’ pane.  

 
N.B. If you choose a name that already exists for a Checkbook you will be prompted 
to enter a different one.  
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· To edit an existing Checkbook double-click its name or click on the  
button second-left of it (NOT the one with an ‘X’ inside) in the ‘My 
Checkbooks’ pane. 
Alternatively click on the Checkbook’s name to highlight it and then go to the 
‘Edit Checkbook’ option in the ‘Edit’ menu.  

· This will open the ‘Edit Checkbook’ box.  
· Enter the Checkbook’s new name and/or Starting Balance and click OK.  
· The Checkbook’s new name will be shown in the Checkbook list in the ‘My 

Checkbooks’ pane. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. If you choose a name that already exists for a Checkbook you will be prompted 
to enter a different one. You cannot edit a Checkbook’s Starting Check Number. 
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· To remove a Checkbook, (and thus all of their Credits/Debits) click on the 
button leftmost of their name (the one with an ‘X’ inside) in the ‘My 
Checkbooks’ pane.  

· Click OK to confirm. 
                                                 
1 Which has value ‘1’ by default for each Checkbook. The first Check Debit that is recorded for this 
Checkbook has whatever value is entered here by default. Check Numbers are unique per Checkbook.  
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All the Credits & Debits that you record will be sorted by date into a spreadsheet of 
records in this pane. Each record has 2 buttons on the right for editing and deleting 
respectively. 
 
N.B. this will be empty of course if no Credits/Debits have been recorded yet.  
The total number of Credits/Debits and their affect on the Current Balance and 
Available Balance is presented at the bottom of this pane (see 2.5 for more on this). 
 
����� ������
N.B. there must be at least one Checkbook before you can start recording 
Credits/Debits.  
�
������� �������

· Click ‘New Credit’ from the ‘Edit’ menu to open the ‘Add’ box.  
· Select the Checkbook of the Credit from the drop-down menu. 
· Select the Credit Type from the drop down menu and click OK. 
· Enter the exact amount of the Credit in the amount field. 
· Check the Credit’s date2 and alter if necessary by clicking the ‘Choose Date’ 

button. This opens the ‘Select a Date’ box presenting you with a calendar - use 
the ‘Prev’ and ‘Next’ buttons to find the Credit’s date and click on it. 

· Give your Credit a description e.g. ‘My First Salary!’ in the text area below. 
· If the Credit type is a ‘Salary’ then use the ‘Repeating transaction’ tick box to 

decide whether to you want to repeat the record for up to one year ahead. 
· A new record for that Credit will be entered in the spreadsheet of the ‘My 

Credits/Debits’ pane. 
 
�
�
�
�
�
�
�
�
�
�
�
�
�
�

                                                 
2 Current date by default 
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· Click ‘New’ from the ‘Edit’ menu to open the ‘Add’ box.   
· Select the Checkbook of the Debit from the drop-down menu. 
· Select the Debit Type from the drop down menu and click OK. 
· Enter the exact amount of the Debit in the amount field.  
· Enter the name of the Debit’s Payee in the text field. 
· Check the Debit’s date2 and if necessary alter it by clicking the ‘Choose Date’ 

button. This opens the ‘Select a Date’ box presenting you with a calendar - use 
the ‘Prev’ and ‘Next’ buttons to find the Debit’s date and click on it. 

· Give your Debit a description e.g. ‘First Rent Payment’ in the text area below. 
· If the Debit Type is a ‘Check’ then verify its Check Number3 and Cleared4 

status too.  
· If the Debit Type is a ‘Standing Order’ or ‘Direct Debit’ then use the 

‘Repeating transaction’ tick box to decide whether to you want to repeat the 
record for up to one year ahead. 

· A new record for that Debit will be entered in the spreadsheet of the ‘My 
Credits/Debits’ pane. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If your new Credit has not been recorded ensure that you aren’t using a filter, which 
may have hidden the data (see section 2.3).  
If you wish to define your own Credit or Debit Type use the ‘Manage Credit Types’ 
or ‘Manage Debit Types’ feature respectively (see section 3.6). 
 

                                                 
3 The first check you record will use the Starting Check Number and subsequent checks will by default 
follow on from this number. 
4 Signify whether a Check Debit has cleared or not. If not leave the box unticked - these Debit records 
are highlighted in red. See Section 3.1 to define whether Uncleared checks should be subtotalled or 
affect the Available Balance. 
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· To edit a Credit/Debit record either click the button directly to the right of it, 

double-click the record or click on the record & go to the ‘Edit Credit/Debit’ 
option in the ‘Edit’ menu. 

· This opens the ‘Edit’ box.  
· Edit the necessary details here as if a new Credit/Debit record were being 

created and then click OK.  
· The Credit/Debit’s record will be updated in the spreadsheet in the  

‘My Credits/Debits’ pane.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
N.B. For an existing Credit/Debit record you cannot edit the Checkbook it has been 
assigned to, or whether it is a repeating transaction. 
If your changes have not been made then open the record up for editing again to make 
sure the details have been entered correctly. 
�
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Use the ‘View’ button (circled below) for each Checkbook in the ‘My Checkbooks’ 
pane whose Credit/Debit records you wish to view.  
This feature may be useful if for example you have one personal Checkbook and one 
business Checkbook and only wish to view their Credit/Debit records.  
Below you can see the Credit/Debit records for the ‘Alex: Business’ and ‘Alex: 
Personal’ Checkbooks. 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Another way to view the Credit/Debit records of interest from this pane is to use the 3 
drop-down filter menus at the top, which are for month, year and Credit/Debit types.  
To see all of particular type e.g. ‘Credits only’, ‘Standing Order only’ select the 
desired option from the top right drop-down filter menu.  
 
Similarly to see the Credits/Debits made in a particular year e.g. 2006 select it from 
the top middle drop-down filter menu. Filter the date of the Credit/Debit further by 
selecting the ‘Month’ from the top-left drop-down filter menu.  
In the figure below you can only see the Check Debits for the ‘Alex: Business’ and 
‘Alex: Personal’ Checkbooks.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too.  
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In the figure below note that the records for the Checkbooks viewable are sorted in 
primarily in Date order then by the Checkbook then the Type then the order that they 
were recorded for that Type. This is the default way the data is sorted i.e. a 
combination of Date, Checkbook & Type to make the Checkbooks of the records you 
are viewing clear. 
If you have sorted your data using any of the other fields you can go back to this 
default by clicking on the Date field such that the order indication arrow is pointing 
up (circled below). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You can customise the order of the records in the main spreadsheet of the ‘My 
Credits/Debits’ pane by clicking on the desired fieldname that you wish to sort by e.g. 
Amount. The direction of the arrow is indicative of the order of sorting and the arrow 
is slightly darker to indicate the current sort field.  
In the figure below you can see the data for the Checkbook is sorted down the pane 
in ascending order of Credit/Debit amount. 

 
 
 
 
 
 
 
 
 
 
 
�
�
�
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A Checkbook’s Current Balance is calculated as the sum of its Starting Balance, 
Credit records and Debit records (these have a negative effect). Its Available Balance 
is the sum of its Starting Balance, Credit Records and Debit records that are NOT 
Uncleared Checks.  
See figure below and note that the Checkbook ‘Alex: Business’ (Starting Balance of 
$2000.00) has a Current Balance of $903.00 (the sum of its Credits & Debits) and an 
Available Balance of $1228.00. The latter shows the Checkbook’s balance bearing in 
mind there is an Uncleared Check (‘Rob’s September Salary’) of $325.00. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now look at the figure below where “Rob’s September Salary” has been edited as a 
Cleared check (see 2.2 for more on this). The Available Balance of ‘Alex: Business’ 
is now also $903.00 
�
�
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. If more than one Checkbook is in View (see 2.3) then the Current Balance and 
Available balance for each Checkbook are each summed and displayed as Total 
Current Balance and Total Available Balance respectively.�
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Key preferences can be customised here to best suit your data.   

· Go to the ‘Preferences’ option in the ‘Edit’ menu to open the Preferences box.  
The drop down menus here allow you to:  

· Customise the currency of your Credits/Debits between ‘$ Dollars’, ‘�  Euros’ 
and ‘£ Pound Sterling’. 

· Choose the default filters for the ‘My Credits/Debits’ pane (e.g. if you would 
like to see only 2006 Credit/Debit records by default).  

· Choose the date format that suits you best between DD.MM.YYYY or 
MM.DD.YYYY  

· Choose whether Check Debits that are Uncleared (they’re shown in red text) 
should be included in the Subtotal and Available Balance calculations. If you 
are unsure whether to use this option it is recommended you leave it as the 
default, which is not ticked (see the figure below).  

 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too. Changing 
the Default unit only affects the visual appearance of the data. No currency 
conversion is involved.  
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· To save your data choose the ‘Save’ option from the ‘File’ menu.  
· Click Close in the ‘Saving’ box then shown. 
· This will record the data to 5 comma separated value files 

CheckbookAccounts.csv, Debits.csv, Credits.csv, DebitType.csv and 
CreditType.csv in your Check Book directory folder5. 

These data files are used to store the details of the Checkbook for the application each 
time it loads. 
 
N.B. These data files can be viewed using standard spreadsheet software6 though this 
is not advised as changes made here may cause failure to load the data when the 
application is next run.    
If the ‘Saving’ box reports that ‘Your data has not been saved’ make sure that these 
data files have not been left open outside of the MyCheck Book 3 application. 
                                                 
5 By default C:\Program Files\Sprite\Check Book\Data 
6 Microsoft Excel, OpenOffice Calc, StarOffice Calc 
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· To export all Checkbook data choose the ‘Export’ option in the ‘File’ menu.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

· Browse to the directory on your computer that you would like to export your 
data to (use the ‘Make New Folder’ button if necessary to create a new 
directory for your exports)  

· Give your export a filename e.g. ‘TrackerJourney’ and click Save. 
· Now outside of the application navigate to the directory chosen and locate the 

file. 
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· Open this using standard spreadsheet software and you will see the data you 

have recorded in a detailed, presentable form.  
e.g. to archive your Credit/Debits or for analysis without the MyCheck Book 3 
application.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

· Below shows a typical use for the exported data, graphing the dates against the 
amount of the Credits/Debits for the ‘Alex: Business’ Checkbook. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. Credits/Debits that MyCheck Book 3 loads are not dependent on exported data 
files.  
If the ‘Exporting’ box reports that ‘Your data has not been saved’ make sure that this 
exported data file has not been left open outside of the MyCheck Book 3 application. 
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· To revert your data to that which was last saved choose the ‘Revert’ option in 

the ‘File’ menu.  
· This will open a warning box - click OK or Cancel to confirm or deny the 

revert action. 
 
 
�
�
�
�
�
�
�
�
�
�
�
�
�
�
�
�
�
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· To print your data choose the ‘Print’ option in the ‘File’ menu. 
· This will open a window where you can select the printer and edit the 

preferences for your print job like you would any standard document.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
· Click Print when ready. 

N.B. this feature will print the data that is currently being viewed see 2.3 for more on 
this. 
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This facility lets you create your own Credit or Debit types to add to the list of default 
ones provided e.g. Salary, Standing Order. You can select from these just as you 
would any of the default ones and use the filters with them too (See section 2.3). 
 

· Click ‘Manage Credit Types’ or ‘Manage Debit Types’ from the ‘Edit’ menu. 
You will be shown a list of the Credit or Debit types that you have created.  

· Click the ‘New Type’ button to open the ‘New Type’ box. Enter the name of 
the Credit or Debit type that you wish to create, click OK and then ‘Done’ 
when ready.   

· The list of types will be updated to include this when you go to create a new 
Credit or Debit respectively.  

· To delete a Credit or Debit type, select it from the list and click the ‘Delete 
Type’ button in the ‘Manage Description Presets’ box. Click OK or Cancel to 
confirm or deny the deletion and any records of this type if they exist too. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If you choose a name that already exists for a type (user defined or default) you will 
be prompted to enter a new one.  
 
N.B. deleting one of your own Credit or Debit types will remove it from any Credit or 
Debit type lists. If you have created any records using one of these types however you 
will be warned that these records will also be deleted.  
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(For more information on synchronisation with BlackBerry see section 4). 
 
When data is synchronised from MyCheck Book 3 for BlackBerry the data files (.csv) 
saved in the ‘Data’ folder will be archived in the ‘Backup’ folder of the  
MyCheck Book 3 desktop application.  
You may wish to load one of these backups into the desktop application as follows: 
 

· To load a data backup choose the ‘Load Backup’ option in the ‘File’ menu. 
· In the ‘Backup’ box that opens, select the date of the backup you wish to load 

from the list and click ‘Load Backup’ (or click Cancel to quit). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
· The confirmation box informs you that the backup data has been successfully 

loaded and how to proceed. 
 
 
You may now continue to use the application with this backup data  - choose ‘Save’ 
from the ‘File’ menu to make the changes permanent next time you load the 
application - OR reload the previous data choosing ‘Revert’ from the ‘File’ menu (see 
section 3.4)��
�
�
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MyCheck Book 3 can be used in conjunction with the MyCheck Book 3 for  
BlackBerry application, to synchronise your Credit/Debits.  
The most recently saved data either the BlackBerry or in the Desktop application are 
synced across. 
 
N.B. The data you may have recorded will be backed up in the \Backup\ directory 
when you synchronise with the BlackBerry, provided you have saved your data   
(See section 3.2) and have quit the application when synchronisation occurs.  
To load these backups see section 3.7. 
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Requirements: 

· MyCheck Book 3 for BlackBerry7 
· BlackBerry Desktop Manager8 
· USB cable to connect BlackBerry to Computer. 
  

You must first install the provided ‘Sync Manager’ Add-in to your BlackBerry to 
allow you to synchronize the MyCheck Book 3 for BlackBerry data with your desktop 
version. 
 
Step-by-step instructions on Windows PC: 
 

1. Connect the BlackBerry device to your computer. 
 
2. Register the Add-in by going to the  

Start Menu > MyCheck Book 3 > Configure BlackBerry Add-in 
 This launches the ‘MyCheck Book 3 Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click the ‘Register’ button and then close the Sync Manager. 

                                                 
7 The BlackBerry version of the application can be obtained from http://berry.handyx.net/ 
8 This is software that comes as standard with your BlackBerry and needs to be installed on your 
computer. Its default location is C:\Program Files\Research In Motion\BlackBerry\DesktopMgr.exe 
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4.  To run the Add-in open your BlackBerry Desktop Manager and double-click 
‘Synchronize’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Click the ‘Configure Add-ins’ button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Check the box next to ‘Sprite MyCheck Book Desktop’ and click OK. 
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7. Back in the ‘Synchronize’ window check the boxes shown and click 
‘Synchronize now’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
8. Another window will appear with a progress bar of the synchronisation 

process. 
 
9. When this has completed, click ‘Close’ on the ‘Synchronize’ window and exit 

the Desktop Manager application. 
 
10. Launch both device and desktop MyCheckBook applications to confirm the 

data has been synced (to load the previous data see section 3.4 or if you have 
saved this new data - section 3.7) 
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Step-by-step instructions on Windows PC: 
1. Connect the BlackBerry device to your computer. 
 
2. Remove the add-in by going to the  
 Start menu > MyCheck Book 3 > Configure BlackBerry Add-in 
 This launches the ‘MyCheck Book 3 Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Click the 'Unregister' button and then close the Sync Manager. 
 
4. Check the add-in has been removed open your BlackBerry Desktop Manager 

and double-click ‘Synchronize'. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Click the ‘Configure Add-ins’ button.  
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6.  The 'Sprite MyCheck Book Desktop’ add-in should no longer be there.  
 Click OK and close the Synchronize window and Desktop Manager    


