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The MyExpenseTracker desktop application is designed to help you record the 
expenses of you and/or your clients/projects including the dates on which they 
occurred, how much the expense(s) cost, what type of expense it was etc. 
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In this pane you will find an alphabetical list of Clients/Projects to the left of which 
there are 2 buttons for deleting & editing each Client/Project respectively. 
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· To create new Clients/Projects choose the ‘New Client’ option in the ‘Edit’ 
menu. 

· This will open the ‘Add Client/Project’ box.  
· Enter the new Client/Project’s name in the text field and click OK. 
· The new Client/Project will be added to the Client/Project list in the ‘My 

Clients/Projects’ pane.  
 
If you choose a name that already exists for a Client/Project you will be prompted to 
enter a different one. 
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· To edit the name of an existing Client/Project double-click their name or click 
on the button directly left of it (NOT the one with an ‘X’ inside) in the ‘My 
Clients/Projects’ pane. 
Alternatively click on the Client/Project’s name to highlight it and then go to 
the ‘Edit Client/Project’ option in the ‘Edit’ menu. 

· This will open the ‘Edit Client/Project’ box. 
· Enter the Client/Project’s new name and click OK. 
· The Client/Project’s new name will be shown in the Client/Project list in the 

‘My Clients/Projects’ pane. 
 
If you choose a name that already exists for a Client/Project you will be prompted to 
enter a different one. 
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· To remove a Client/Project, (and thus all of their expenses) click on the button 
leftmost of their name (the one with an ‘X’ inside) in the ‘My Clients/Projects’ 
pane.  

· Click OK to confirm. 
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All the expenses that you record will be sorted by date into a spreadsheet of records in 
this pane. Each record has 2 buttons on the right for editing and deleting. 
 
N.B. this will be empty of course if no expenses have been recorded yet.  
The total number of expenses and their amount is presented at the bottom of this pane. 
 
 
����� ���������	�
�����
���
N.B. there must be at least one Client/Project before you can start recording expenses.  
 

· Click ‘New Expense’ from the ‘Edit’ menu to open the ‘Add expense’ box.   
· Select the Client/Project of the expense from the drop-down menu and click 

OK. 
· Enter the exact amount of your expense in the amount field. 
· Check the expense’s date1 and if necessary alter it by clicking the ‘Choose 

Date’ button.  
This opens the ‘Select a Date’ box presenting you with a calendar - use the 
‘Prev’ and ‘Next’ buttons to find the expense’s date and click on it. 

· Give your expense a description e.g. ‘Team Training Seminar’ in the text area 
below and/or click the ‘Presets’ button to use predefined description text (see 
section 3.6) 

· A new record for that expense will be entered in the spreadsheet of the ‘My 
Expenses’ pane. 

 
If your new expense has not been recorded, check that you aren’t using a filter, which 
may have hidden the data (see section 2.3).  
If you wish to define your own description preset use the ‘Manage Description 
Presets’ feature (see section 3.6). 
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· To edit details such as the amount of an existing expense, click the button 
directly to the right of the expense’s record or double-click the record.  
Alternatively click on the expense record to highlight it and then go to the 
‘Edit Expense’ option in the ‘Edit’ menu. 

· This opens the ‘Edit Expense’ box.  
· Edit the necessary details here as if a new expense were being created and then 

click OK. 
· The expense’s record will be updated in the spreadsheet of the My Expenses 

pane. 
 
N.B. you cannot change the Client/Project of an existing expense.  
If your changes have not been made then open the record up for editing again to make 
sure the details were entered correctly. 
�

                                                 
1 Current date by default 
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To help extract the expenses of interest from this pane, 3 drop-down filter menus are 
provided for the month, year and Clients/Projects whose expenses you wish to see. 
 
To see the expenses made by an existing Client/Project e.g. ‘David’, select the 
Client/Project from the top right drop-down filter menu.  
 
Similarly to see the expenses made in a particular year e.g. 2006 select it from the top 
middle drop-down filter menu. Filter the date of the expense further by selecting the 
‘Month’ from the top-left drop-down filter menu. 
 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too. 
�
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You can customise the order of the expense records in the main spreadsheet of the 
‘My Expenses’ pane by clicking on the desired field to sort by. The direction of the 
arrow is indicative of the order of sorting and the arrow is slightly darker to indicate 
the current sort field. Below the data is sorted in descending order by ‘Amount’ i.e. 
the most costly expenses appearing on top: 
 
 
 
 
 
 
 
 
 
 
 
�
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N.B. by default the data is sorted in ascending order by date i.e. the newest expenses 
are presented at the bottom. 
�
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Key preferences of the Expense Tracker can be customised here to best suit you or 
your Clients/Projects’ expenses.   
 

· Go to the ‘Preferences’ option in the ‘Edit’ menu to open the Preferences box.  
· The drop down menus here allow you to switch the currency of your expenses 

between ‘$ Dollars’, ‘�  Euros’ and ‘£ Pound Sterling’, choose the default 
filters for the ‘My Expenses’ pane (e.g. if you would like to see only 2006 
expenses by default) and/or switch to the date format that suits you. 

 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too. 
Changing the ‘Default unit’ here affects only the visual appearance of the data. No 
currency conversion is involved. 
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· To save your expense & Client/Project data choose the ‘Save’ option in the 
‘File’ menu.  

· Click Close in the ‘Saving’ box shown. 
· This will record the Expense Tracker’s data into 2 comma separated value 

files TrackerClientProject.csv and TrackerExpenses.csv in your 
ExpenseTracker folder2. 

 
These data files are used to store the details of the expenses for the application each 
time it loads. 
 
N.B. These data files can be viewed using standard spreadsheet software3 though this 
is not advised as changes made here may cause a failure in loading the data when the 
application is next run. 
 
If the ‘Saving’ box reports that the ‘Your data has not been saved’ make sure that 
these data files have not been left open outside of the MyExpenseTracker application. 
 

                                                 
2 By default C:\Program Files\Sprite\Expense Tracker\Data 
3 Microsoft Excel, OpenOffice Calc, StarOffice Calc 
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· To export your expense data choose the ‘Export’ option in the ‘File’ menu.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

· Browse to the directory on your computer that you would like to export your 
data to (use the ‘Make New Folder’ button if necessary to create a new 
directory for your exports)  

· Give your export a filename e.g. ‘TrackerJourney’ and click Save. 
· Now outside of the application navigate to the directory chosen and locate the 

file. 
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· Open this using standard spreadsheet software and you will see the Expense 

data you have recorded in a detailed, presentable form.  
e.g. to archive your expenses or for analysis without the MyExpenseTracker 
application.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

· Below shows typical use for the exported data, graphing the expense dates 
against the amount spent for all the Clients/Projects. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. expenses that MyExpenseTracker loads are not dependent on the exported data 
file.  
If the ‘Exporting’ box reports that ‘Your data has not been saved’ make sure that this 
exported data file has not been left open outside of the MyExpenseTracker 
application. 
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· To revert your data to that which was last saved choose the ‘Revert’ option in 

the ‘File’ menu.  
· This will open a warning box - click OK or Cancel to confirm or deny the 

revert action. 
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· To print your expense data choose the ‘Print’ option in the ‘File’ menu. 
· This will open a window where you can select the printer and edit the 

preferences for your print job like you would any standard document.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
· Click Print when ready. 
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This (optional) facility lets you create your own predefined description text that you 
can use to when creating expenses. This may be useful if you often, record lots of 
expenses that can be described the same way e.g. ‘Meals & Snacks’ or if you wish to 
append your expense description e.g. ‘Travel – Spain’, ‘Travel – Italy’.  
 

· Click ‘Manage Description Presets’ from the ‘Edit’ menu. You will be shown 
a list of the description presets that you have created.  

· Click the ‘New Preset’ button to open the ‘New Description Preset’ box. Type 
in the name of the description preset you wish to create, click OK and then 
‘Done’ when ready. 

· The expense ‘Presets’ list will be updated.  
· To delete a description preset select it from the list and click the ‘Delete 

Preset’ button in the ‘Manage Description Presets’ box. Click OK or Cancel to 
confirm or deny the deletion. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If you choose a name that already exists for a description preset (user defined or 
default) you will be prompted to enter a new one.  
 
N.B. deleting one of your own description presets will remove it from any preset lists 
but will not delete any expenses that have been created using it. 
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(For more information on synchronisation with BlackBerry see section 4). 
 
When data is synchronised from MyExpenseTracker for BlackBerry the expense data 
files (.csv) saved in the ‘Data’ folder will be archived in the ‘Backup’ folder of the 
MyExpenseTracker desktop application.  
You may wish to load one of these backups into the desktop application as follows: 
 

· To load an expense data backup choose the ‘Load Backup’ option in the ‘File’ 
menu. 

· In the ‘Backup’ box that opens, select the date of the backup you wish to load 
from the list and click ‘Load Backup’ (or click Cancel to quit) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
· The confirmation box informs you that the backup data has been successfully 

loaded and how to proceed. 
 
 
You may now continue to use the application with this backup data  - choose ‘Save’ 
from the ‘File’ menu to make the changes permanent next time you load the 
application - OR reload the previous data choosing ‘Revert’ from the ‘File’ menu (see 
section 3.4)��
�
�
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MyExpenseTracker can be used in conjunction with the MyExpenseTracker for 
BlackBerry application, to synchronise your expenses.  
The data files that MyExpenseTracker records (in the \Data\ directory) will instead be 
replaced with data files from the BlackBerry.  
 
N.B. The data you may have recorded will be backed up in the \Backup\ directory 
when you synchronise with the Blackberry, provided you have saved your data  (See 
section 3.2) and have quit the application when synchronisation occurs.  
To load these backups see section 3.7. 
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Requirements: 

· MyExpenseTracker for BlackBerry4 
· BlackBerry Desktop Manager5 
· USB cable to connect BlackBerry to Computer. 
  

You must first install the provided ‘Sync Manager’ Add-in to your BlackBerry to 
allow you to synchronize the MyExpenseTracker for BlackBerry data with your 
desktop version. 
Step-by-step instructions on Windows PC: 
 

1. Connect the BlackBerry device to your computer. 
 
2. Register the Add-in by going to the  

Start Menu > My Expense Tracker > Configure Blackberry Add-in 
 This launches the ‘My Expense Tracker Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click the ‘Register’ button and then close the Sync Manager. 

                                                 
4 The BlackBerry version of the application can be obtained from http://berry.handyx.net/expense 
5 This is software that comes as standard with your BlackBerry and needs to be installed on your 
computer. Its default location is C:\Program Files\Research In Motion\BlackBerry\DesktopMgr.exe 
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4. To run the Add-in open your BlackBerry Desktop Manager and double-click 
‘Synchronize’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Click the ‘Configure Add-ins’ button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Check the box next to ‘Sprite MyExpenseTracker Desktop’ and click OK. 
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7. Back in the ‘Synchronize’ window check the boxes shown below and click 
‘Synchronize now’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
8. Another window will appear with a progress bar of the synchronisation 

process. 
 
9. When this has completed, click ‘Close’ on the ‘Synchronize’ window and exit 

the Desktop Manager application. 
 
10. Launch both device and desktop MyExpenseTracker applications to confirm 

the data has been synced (to load the previous data see section 3.4 or if you 
have saved this new data - section 3.7) 
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Step-by-step instructions on Windows PC: 
1. Connect the BlackBerry device to your computer. 
 
2. Remove the add-in by going to the  
 Start menu > My Expense Tracker > Configure Blackberry Add-in 
 This launches the ‘MyExpenseTracker Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Click the 'Unregister' button and then close the Sync Manager. 
 
4. Check the add-in has been removed - open your BlackBerry Desktop Manager 

and double-click ‘Synchronize'. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Click the ‘Configure Add-ins’ button.  
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6.  The 'Sprite MyExpenseTracker Desktop’ add-in should no longer be there.  
 Click OK and close the Synchronize window and Desktop Manager 
   


