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The MyMileageTracker desktop application is designed to help you keep track of the 
journeys of you and/or your clients including the dates on which they occurred, where 
the journey took place, the distance that was travelled etc. 
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In this pane you will find an alphabetical list of clients to the left of which there are 2 
buttons for deleting & editing each client respectively. 
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· To create new clients choose the ‘New Client’ option in the ‘Edit’ menu. 
· This will open the ‘Add Client’ box. 
· Enter the new client’s name in the text field and click OK 
· The new client will be added to the client list in the ‘My Clients’ pane.  

 
If you choose a name that already exists for a client you will be prompted to enter a 
different one. 
 
 
����� ������
�������
������
��

· To edit the name of an existing client double-click their name or click on the 
button directly left of it (NOT the one with an ‘X’ inside) in the ‘My Clients’ 
pane. 
Alternatively click on the client’s name to highlight it and then go to the ‘Edit 
Client’ option in the ‘Edit’ menu. 

· This will open the ‘Edit Client’ box. 
· Enter the client’s new name and click OK 
· The client’s new name will be shown in the client list in the ‘My Clients’ 

pane. 
 
If you choose a name that already exists for a client you will be prompted to enter a 
different one. 
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· To remove a client, (and thus all of their journeys) click on the button leftmost 
of their name (the one with an ‘X’ inside) in the ‘My Clients’ pane.  

· Click OK to confirm. 
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All the journeys that you record will be chronologically sorted into a spreadsheet of 
records in this pane. Each record has 2 buttons on the right for editing and deleting. 
 
N.B. this will be empty of course if no journeys have been recorded yet 
The number of journeys and their total distance is presented at the bottom of this 
pane. 
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To record a new journey click ‘New Journey’ from the ‘Edit’ menu to open the ‘Add 
journey’ box 
 
N.B. there must be at least one client before you can start recording journeys. 

· Select the client of the journey from the drop-down menu and click OK. 
· Check the ‘Odometer Start’ reading1 - alter its value if necessary and then 

enter the ‘Odometer End’ reading for your journey to calculate the ‘Odometer 
Difference’.  

· Next check the journey’s date2 and if necessary alter it by clicking the ‘Choose 
Date’ button.  
This opens the ‘Select a Date’ box presenting you with a calendar - use the 
‘Prev’ and ‘Next’ buttons to find the journey’s date and click on it. 

· Finally give your journey a description e.g. ‘Bath to Bristol’ in the box below 
and click ‘OK’. 

· A new record for that journey will be entered in the spreadsheet of the ‘My 
Journeys’ pane.  

 
If your new journey has not been recorded, check that you aren’t using a filter, which 
may have hidden the data (see section 2.3). 
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· To edit details such as the mileage of an existing journey, click the button 
directly to the right of the journey’s record or double-click the record.  
Alternatively click on the record to highlight it and then go to the ‘Edit 
Mileage’ option in the ‘Edit’ menu. 

· This opens the ‘Edit Journey’ box.  
· Edit the necessary details here as if a new Journey were being created and then 

click OK. 
· The journey’s record will be updated in the spreadsheet of the My Journeys 

pane. 
 
N.B. you cannot change the client of an existing journey.  
If your changes have not been made then open the record up for editing again to make 
sure the details were entered correctly. 

                                                 
1 The total distance travelled so far for all clients is the default Odometer start value for subsequent 
‘New Journeys’  
2 Current date by default 
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To help extract the journeys of interest from this pane, 3 drop-down filter menus are 
provided for the month, year and/or clients whose journeys you wish to see. 
 
To see the journeys made by an existing client e.g. ‘Bob’ select the client from the top 
right drop-down filter menu.  
 
Similarly to see the journeys made in a particular year e.g. 2006 select it after clicking 
on the top middle drop-down filter menu. Filter the date of the journey further by 
selecting the ‘Month’ from the top-left drop-down filter menu. 
 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too. 
�



Page 6 of 15 

��� �����
���
����� ������������
����
Key preferences of the Mileage Tracker can be customised here to best suit you or 
your clients’ journeys.   
 

· Go to the ‘Preferences’ option in the ‘Edit’ menu to open the Preferences box.  
· The drop down menus here allow you to switch the units of your journeys 

from miles to kilometres, choose the default filters for the ‘My Journeys’ pane 
(e.g. if you would like to see only 2006 journeys by default) and/or convert to 
the date format that suits you. 

 
N.B. the ‘Month’ filter can only be used when the ‘Year’ filter is in use too. 
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· To save your journey & client data choose the ‘Save’ option in the ‘File’ 
menu.  

· Click Close in the ‘Saving’ box shown. 
· This will record the Mileage Tracker’s data into 2 comma separated value files 

TrackerClient.csv’ and TrackerJourneys.csv in your MyMileageTracker 
folder3. 

 
These data files are used to store the details of the journeys and mileage tracker for 
the application each time it loads. 
 
N.B. These data files can be viewed using standard spreadsheet software4 though this 
is not advised as changes made here may cause a failure in loading the data when the 
application is next run. 
 
If the ‘Saving’ box reports that the ‘Your data has not been saved’ make sure that 
these data files have not been left open outside of the MyMileageTracker application. 
 
 

                                                 
3 By default C:\Program Files\Sprite\Mileage Tracker\Data 
4 Microsoft Excel, OpenOffice Calc, StarOffice Calc 
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· To export your journey data choose the ‘Export’ option in the ‘File’ menu.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
· Browse to the directory on your computer that you would like to export your 

data to (use the ‘Make New Folder’ button if necessary to create a new 
directory for your exports)  

· Give your export a filename e.g. ‘TrackerJourney’ and click Save. 
· Now outside of the application navigate to the directory chosen and locate the 

file.  
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· Open this using standard spreadsheet software and you will see the Mileage 

data you have recorded in a detailed, presentable form.  
e.g. to archive your journeys or for analysis without the MyMileageTracker 
application.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

· Below shows typical use for the exported data, graphing the journey data 
against the distance travelled. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
N.B. journeys that MyMileageTracker loads are not dependent on the exported data.  
If the ‘Exporting’ box reports that ‘Your data has not been saved’ make sure that 
these data files have not been left open outside of the MyMileageTracker application. 
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· To revert your data to that which was last saved choose the ‘Revert’ option in 

the ‘File’ menu.  
· This will open a warning box - click OK or Cancel to confirm or deny the 

revert action. 
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· To print your journey data choose the ‘Print’ option in the ‘File’ menu. 
· This will open a window where you can select the printer and edit the 

preferences for your print job like you would any standard document.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
· Click Print when ready. 
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(For more information on synchronisation with BlackBerry see section 4). 
 
When data is synchronised from MyMileageTracker for BlackBerry the journey data 
files (.csv) saved in the ‘Data’ folder will be archived in the ‘Backup’ folder of the 
MyMileageTracker desktop application.  
You may wish to load one of these backups into the desktop application as follows: 
 

· To back up your journey data choose the ‘Load Backup’ option in the ‘File’ 
menu. 

· In the ‘Backup’ box that open select the date of the backup you wish to load 
from the list and click ‘Load Backup’  (or click Cancel to quit) 

· The confirmation box informs you that the backup data has been successfully 
loaded and how to proceed. 

· You may now continue to use the application with this backup data, choose 
‘Save’ from the ‘File’ menu to make the changes permanent next time you 
load the application OR reload the previous data by choosing ‘Revert’ from 
the ‘File Menu’ 
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MyMileage Tracker can be used in conjunction with the MyMileage Tracker for 
BlackBerry application, to synchronise your journeys.  
The most recently saved data either the BlackBerry or in the Desktop application are 
synced across. 
 
N.B. The data you may have recorded will be backed up in the \Backup\ directory 
when you synchronise with the BlackBerry, provided you have saved your data  (See 
section 3.2) and have quit the application when synchronisation occurs.  
To load these backups see section 3.7 
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Requirements: 

· MyMileageTracker for BlackBerry5 
· BlackBerry Desktop Manager6 
· USB cable to connect BlackBerry to Computer 
  

You must first install the provided ‘Sync Manager’ Add-in to your BlackBerry to 
allow you to synchronise the MyMileageTracker for BlackBerry data to your desktop 
version. 
Step-by-step instructions on Windows PC: 
 

1. Connect the BlackBerry device to your computer. 
 
2. Register the Add-in by going to the  

Start Menu > My Mileage Tracker > Configure Blackberry Add-in 
 This launches the ‘MyMileage Tracker Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click the ‘Register’ button and then close the Sync Manager. 

                                                 
5 The BlackBerry version of the application can be obtained from http://berry.handyx.net/mileage 
6 This is software that comes as standard with your BlackBerry and needs to be installed on your 
computer. Its default location C:\Program Files\Research In Motion\BlackBerry\DesktopMgr.exe 
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4. To run the Add-in open your BlackBerry Desktop Manager and double-click 
‘Synchronize’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Click the ‘Configure Add-ins’ button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Check the box next to ‘Sprite MyMileageTracker Desktop’ and click ‘OK’. 
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7. Back in the ‘Synchronize’ window check the boxes shown and click 
‘Synchronize now’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
8. Another window will appear with a progress bar of the synchronisation 

process. 
 
9. When this has completed, click ‘Close’ on the ‘Synchronize’ window and exit 

the Desktop Manager application. 
 
10. Launch both device and desktop MyMileageTracker applications to confirm 

the data has been synced (to load the previous data see section 3.4 or if you 
have saved this new data - section 3.7) 
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Step-by-step instructions on Windows PC: 
1. Connect the BlackBerry device to your computer. 
 
2. Remove the add-in by going to the  
 Start menu > My Mileage Tracker > Configure Blackberry Add-in 
 This launches the ‘MyMileage Tracker Sync Manager’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Click the 'Unregister' button and then close the Sync Manager. 
 
4. Check the add-in has been removed open your BlackBerry Desktop Manager 

and double-click ‘Synchronize'. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
5. Click the ‘Configure Add-ins’ button.  
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6.  The 'Sprite MyMileageTracker Desktop’ add-in should no longer be there.  
 Click OK and close the Synchronize window and Desktop Manager 
   


